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1 Nanotubes in VASE

In this exercise set we will use the computer to investigate some properties of carbon nanotubes. Specifically
we use a program called “VASE”, which is a visual interface to some of the research codes used in the CAMD
group of the department of physics. Basic instructions for “VASE” are in a separate document. It will save
you time later if you at least have a quick look at them before starting the exercises below.
Some hints regarding VASE follow:

• Read the VASE instructions! It will save you time and you can find instructions on how to set up the
program!

• When you start the program from a terminal you can type “VASE Carbon”, instead of just “VASE”,
then only the structures relevant to this exercise set will be available, which will perhaps save a little
time when navigating the Structures menu.

• In this document, underlined words indicate VASE buttons.

• Use the program “xmgrace” to make plots of your data, unless you are familiar enough with some other
software that you can do curve fitting etc, with. Instructions for xmgrace are provided separately.

• For all of this work you should use the “Asap” calculator, which is selected by default. When carbon
atoms are being simulated, as here, what this means is that the rule used for calculating energies and
forces of atoms is the one called the “Brenner potential for carbon”, which is commonly used in this
kind of simulation.

• We have to be a little careful when using Asap/Brenner for nanotubes. Those with very short unit
cells can cause it to give wrong results1. So for all calculations involving symmetric nanotubes, that
is armchair (n = m) and zig-zag (m = 0), and using Asap/Brenner, set the number of unit cells in the
nanotube parameter menu to 2. This is separate from the number of unit cells in the Visualize menu,
which is purely for visualizing and doesn’t affect the calculations.

• Hints on how to solve the exercises are typically given under each exercise in this document.

We will mostly be calculating the potential energy of different structures. The next section talks about
why this is useful in general.

2 Why potential energy?

Energy is a very important concept in many branches of physics. Generally, any system will, if you leave
it for a long time, try to find equilibrium, which means a state of lowest possible energy. Different kinds of
energy may be involved: In mechanics, it’s the potential energy. In quantum mechanics, it’s a kind of mixture

1because of the periodic boundary conditions length being shorter than the range of the potential, so each atom “sees” its
neighbors twice.
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of kinetic and potential energy. In thermodynamics, it’s something called the “free energy”. Exceptions to
this principle usually involve having a source of energy that is added to the system, for example solar energy
keeps the earth’s weather systems from ever settling down for long.

In these exercises, we are looking at mechanical properties of nanotubes, and we will be using computa-
tional methods that work at zero temperature. Thus the relevant kind of energy is the potential energy of
the system. If the system is a single particle experiencing a force (for example gravity), then one is interested
in what position of the particle has the lowest energy. But there are often many particles, such as all of
the atoms in a crystal, or a sheet of graphene, or a nanotube. So when we talk about finding the lowest
potential energy, in principle that means thinking about changing all the coordinates (x, y and z) of all the
atoms! However, we only care about some overall measure of the system’s state, such as it’s length or volume
or whether it’s been distorted in some way and not all the positions of the atoms. Then we can write (or
calculate) the energy as a function of that variable (“degree of freedom” is the phrase most often used), and
see where the energy is lowest. This will then be the preferred value for that variable.

If a system is not quite at its minimum-energy configuration/state, then there will be some kind of force
acting on it to move it towards the minimum. For a single particle this is just what we normally think of as
a force. If we’re thinking about a solid and trying to change its volume, the “effective force” is the pressure
(trying to reduce the volume of a solid requires a pressure, which is resisted by an equal pressure from the
solid itself). Stretching something is associated with stress (which is related to pressure).

3 Nanotubes: Structure, visualization

The first thing to do is just to create the structures and visualize them. Choose any kind of nanotube and
Visualize it. Like crystals, carbon nanotubes have a “unit cell”, which repeats along the tube axis. By
default, one unit cell is shown. The more symmetric tubes, arm-chair and zig-zag, have small unit cells, so
they look more like rings than tubes if you only show one cell. If you click Visualize again and this time
choose 3 or 4 repetitions in the z-direction, you’ll get a better sense of it as a tube. Use the mouse to rotate
the tube around to see it from different angles.

*Question 1 : Pick three different nanotubes, visualize them, and write down how many atoms are in their
unit cells. For each one say what kind of tube it is. Make a printout of at least one visualization (use
Export Postscript).

4 Nanotubes: Energy vs curvature

4.1 Relation between nanotubes and graphene

Here we will look at the potential energies of different kinds of nanotubes. If you have a piece of material,
the potential energy will be roughly proportional to the number of atoms, so if you want to compare two
different nanotubes, which may have different number of atoms per unit cell, you should not compare the
total energies, but rather the energy per atom. Saying that this tube has a lower energy than that one doesn’t
mean much if the numbers of atoms are different. (Later we will be more interested in the total energy).

Now, remember that nanotubes are like rolled-up graphene sheets. In the surface of a nanotube the
atoms are bonded to each other like in graphene - therefore the energy per atom in a nanotube is very close
to that of graphene. In fact, as you make the diameter larger and larger it is almost identical. The difference
must therefore be related simply to the fact that the “graphene sheet” of the nanotube is curved rather than
flat (this is not quite true for small diameters).

4.2 Energy of graphene

Let us start by working with a graphene sheet.

*Question 2 : Find out how many atoms VASE uses in the “unit cell” of graphene.

2



Choose graphene as the structure, leaving all parameters at their default values, and do Visualize. This
is the number of atoms in the “unit cell” that VASE uses for graphene. Actually graphene can be repre-
sented as a lattice with just two atoms per unit cell, but such a system is too small for the Brenner potential
to calculate correctly. Next, do it again, but in the Visualize menu, select the number of unit cells to be 3
or 4 in the X and Y directions, so you will see many unit cells of the lattice and get a feeling for graphene
as a sheet which is a repeating lattice of carbon atoms.

The default value for the carbon-carbon bond length should be the optimal one (the one that gives the
lowest energy), but check this by calculating the energy for varying bond length.

*Question 3 : Construct a figure showing the total energy in eV as a function of the C-C bond length in Å
for carbon in graphene. What is the optimal C-C bond length and the energy per atom at this bond length?
Explain qualitatively the shape of the graph.

Note: it might save you time to use the Vary Structural Parameter button, which you can use to change the
C-C length automatically and record the energies in a file.

4.3 Energy of a nanotube

We will start by making the assumption that the C-C bond length is the same in the nanotube as it is in
a graphene sheet. This is not necessarily true, but it probably won’t change much, and we can check for
differences later.

Question 4 : Choose a nanotube, say the default (5,5) one. Calculate the energy per atom for one, two,
three and four unit cells. It should be the same except for when there’s only one.

As just found (and mentioned above), you should set the number of included unit cells in the following
calculations to be two, otherwise the energy won’t be correct.

*Question 5 : Calculate the energy per atom for several arm-chair nanotubes, i.e. (n, n) and zig-zag
nanotubes, i.e. (n, 0) with n ranging from 3 to 20 (choose maybe 8 or 9 values). Unfortunately it is not
possible to use Vary Structural Parameter in this case due to a bug in the program, so here you will have to
do it manually. Make a plot of the energy per atom vs n containing the data for both types of nanotubes.
Use the formulas you have derived for the diameter of (n, 0) and (n, n) nanotubes to make a second plot
of the energy per atom vs d (diameter). In both plots include the energy per atom for the graphene sheet.
Comment on what is seen on the two plots.

*Question 6 : For two of the nanotubes you have used, instead of assuming that the C-C bond length
stays the same as graphene, go through the procedure we did with graphene, varying the bond length, and
finding out which one gives the minimum energy. Write down the new bond lengths, the new energies, and
the difference compared with the old values.

4.4 Nanotubes: Strength

OK, so now let’s get to the real fun. How strong are nanotubes, in fact?2 First let’s figure out how to get
the force (the tension in the tube) as a function of how much it is stretched.

For a particle subject to a force which is a function of its position, one can represent the force as the
negative derivative of the potential energy (often you start knowing the potential energy as a function of
position and derive the force3). What we can most easily calculate for nanotubes is the potential energy.
If we vary the length of the tube (not by changing the number of atoms, but by stretching it to different
amounts), we can think of it as like a particle under the influence of a force; for example, imagine that one
end of the tube is fixed and the other is the supposed “particle”—imagine that you are holding on this end

2Or at least maybe not in fact, but according to the Brenner potential.
3This doesn’t apply to all forces, only ones which are so-called “conservative forces”.
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and trying to stretch the tube4. The force is just the derivative of the whole tube’s potential energy with
respect of the position of the end, in other words: the derivative of the total energy with respect to the
length.

*Question 7 : Make a plot of both the total energy vs the length in Å of a (5,5) nanotube and the force vs
the length in Å. What is the maximum observed force in Newton?

To stretch the nanotube use the function Vertical Strain from the Computations menu to stretch it to twice
its length (scale factor from 1 to 2, in small steps), save the data to a file. Remember, here we need the total
energy, not the energy per atom. The first column here is the scale factor, not the length. Remember that
there should be at least two unit cells for a (5,5) tube, and more would be more realistic, because it allows
more possible deformations to happen (we recommend to use four).

To convert the data to energy-versus-length, we must multiply the x-values by the original length (one
way to find the latter is to use Quick Info and look at the 3,3 entry of the “unit cell”). Multiplying the
data is straightforward in xmgrace. Next, to calculate the force take the derivative of the total energy with
respect to the length; this can also be done in xmgrace.

The maximum force observed is a first estimate of the breaking force of the tube. However, in the
calculation the tube diameter was kept constant, which is unphysical, since the atoms then can’t move to
the minimum energy configuration during the stretching. This we will improve on now.

What we’re going to do now is, as well as simply stretching all the atoms apart from each other uniformly,
now, for each little bit of stretching, we will use an algorithm called MDMin5 which tries to move the atoms
to a minimum-energy configuration. When the tube is unstretched, they are in such a state. Stretching
necessarily increases the energy, but generally by more than it needs to—the atoms, given a chance can find
lower-energy positions even while staying stretched. MDMin works by using a “time step”, during which the
atoms are moved a little bit closer to the minimum-energy configuration. It generally takes many time steps
to get to the minimum. Each one of these steps takes about the same amount of time as a single energy
calculation.

*Question 8 : Repeat the previous question, but this time choose a non-zero number of “MDMin itera-
tions”. Does the new graph look like the one found in the previous question? If not comment on what has
happened. Visualize the nanotube and comment on how it looks after being stretched.

When doing the Vertical Strain computation with a non-zero “Number of MDMin iterations” try to experi-
ment with this number (leave the scale-step at the default to begin with), and see what difference it makes.
Ideally you should have a large number of MDMin iterations, and a very small scale-step, to do this kind
of simulation accurately, but that will take too much time. A good strategy would then be to start with
a small number of iterations, and a large scale-step, and increase/reduce them respectively until the data
doesn’t change much any more. For example you can do 10 MDMin iterations and use a scale-step of 0.1 in
the first calculation. Be aware that the calculations can be quite heavy and may take several minutes.

When visualising the deformed nanotube remember to check Use stored in the Visualize dialog box, in
order to look at the structure that resulted from the calculation, rather than create a fresh undeformed
nanotube.

Depending on what kind of nanotube you simulate, as well as (sometimes) details of how you do the
minimization between steps, and how big the steps are exactly different things can happen6: you can get a
clean break in the tube or defects can be created, such as holes in the hexagonal lattice, or the tube can get
drawn out into a wire of atoms. These deformations can occur via several steps, each of which leads to a
sudden drop in energy. We will use the maximum force observed in the first of these event in the subsequent
calculation.

*Question 9 : Calculate the breaking stress for carbon nanotubes, give it in both eV/Å3 and in GPa.

4The fact that we have periodic boundary conditions confuses this a little bit, but doesn’t actually change the argument.
5This stands for “molecular dynamics minimization”.
6Which is of course is annoying. This business can be as much art as science.
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Compare the found value7 to the value for high strength steel which might have a breaking stress of 0.8GPa.
Comment on the numbers.

In order to be able to make comparisons of a carbon nanotube’s strength with other materials, we need
the so-called stress, which is force per unit area (like pressure, but for pulling). But what area should be
used? For practical purposes that depends on how you would bundle many tubes together, but a simple
approximate way to find an area is to take the cross-sectional area of the tube. Using the C-C bond length
that you initially specified, and the formulas for the diameter that you derived earlier, you can find the
diameter8, and then the area. The number comes out in the units eV/Å3. The usual unit for this kind of
stress is GPa (giga-Pascal) or 109Pa = 109N/m2 . You have to find the conversion factor yourself, before
you can write down the breaking stress of the nanotube in GPa.

This document was written by Nick Bailey, Ture Munter, and Jeppe Gavnholt at CAMD (last updated
August 2007).

7Our calculation is technically a zero-temperature one. The strength would be lower at room temperature.
8You might question the fact that we divide by the undeformed area when presumably it gets narrower as it’s being stretched.

This is standard engineering practice, because measuring the deformed area is not always possible.
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Basic features of the VASE simulation program

1 Introduction

Welcome to VASE. VASE stands for Visual ASE, where ASE stands for Atomic Simulation Environment,
which is the software framework used by the research codes at the Center for Atomic Scale Materials
Design (CAMD), building 307. VASE allows access to the capabilities of ASE and its associated codes
(Dacapo, Asap). While limited, this access still allows reasonably sophisticated simulations to be carried
out. To do more one has to learn the Python programming language and the Python interface to ASE
(http://www.camd.dtu.dk/Software/).

2 Setting it up

Before you can use VASE there is a small thing you need to do for it to work. From your home directory,
type “emacs .grouprc” (space after “emacs”) to bring up a text editor with the .grouprc file (this may or
not already exist). Unless it is there already, add the single line “g10030”. This means you have access to
the teacher’s account for this course, and the related files, including VASE.
In order for the new setup to be active logout and login again. To start VASE start a terminal, make a new
directory for the datafiles from this exercise by typing mkdir 10030, now go to this directory by typing cd
10030. Now start VASE by typing VASE and enter.
You can follow “VASE” with one of the words “Carbon”, “Cluster”, “Surface”. This limits the available
structures to make things a little less crowded. By default all structures are available. After a few seconds
the main menu should appear. It is recommended to leave the terminal window visible because useful
information may be displayed there (error messages are displayed on a pop-up window, however). It might
also be a good idea to have another terminal window open to the same directory so that you can interact
with files that are output by the program.

3 Main menu

The most important buttons are Structures, Visualize, Computations, and RUN. You need these at a
minimum to do anything useful. Basically Structures lets you choose what kind of atomic structure to
work with, Visualize lets you view it in 3D, Computations lets you choose something to calculate or some
simulation to run on the atomic structure, while RUN starts the computation. All the other buttons are
extras of various kinds (often very useful!)

4 Help system

All of the buttons on the main menu and many of the ones in sub-menus have a button beside them saying
“H”. This brings up a little text box with some information about the purpose of the button or how to use
it. All parameters have default values. Until you understand a given parameter, it’s fine to just accept the
default values.
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5 Structures

After clicking on Structures, you first get a choice of structures (what is on the list depends on how you
started VASE). Click beside the desired one and press OK. Then a new window appears which allows you
to specify parameters associated with that structure (for example the radius if the structure is a spherical
cluster, or the type of element, etc). It is possible for a structure to not have any parameters, in which case
the second menu will not appear. The program will remember the parameters next time you go back to that
structure (even if you used a different structure in the meantime).

6 Computations

If you want to do something other than visualize a structure, you need to choose a computation. This is done
from the Computations menu and can be as simple as calculating the (potential) energy of s structure or as
complicated as running a dynamical simulation for many time steps. Again, choosing a computation leads
to a second menu where parameters are chosen, if there are any to choose (there are none for Single Energy,
for example).

7 Running

Clicking RUN will cause whatever you chose in Computations to be done. You might see a box appear
saying “Using fresh ListOfAtoms”, which is just a reminder that this will be a fresh calculation, starting
with a fresh ListOfAtoms. If this is want you want, press OK. Otherwise (for example if you really wanted
to start from the output of the previous calculation) press Cancel and choose Use stored from Structures
The time taken for running will depend greatly on what kind of Computation is chosen. Less than a second
for a single energy using Asap, to several minutes for a short dynamical simulation to an hour or more for
to calculate a few structures using Dacapo (on a small system).

8 Data files

Data from VASE can take many forms. In the case of Vary Structural Parameter and some computations,
the output is in a file by default called “energyCurve.dat” which has three columns. These are (1) the
parameter that is being varied (either a structural parameter or strain etc) (2) the total energy and (3)
the energy per atom (the total energy divided by the number of atoms). The VASE function Plot Data is
designed for this kind of data—it gives you a choice of plotting total energy and energy per atom, which
means choosing the second or third column in the file.

9 Visualizing and printing structures

The structure can be visualized by choosing Visualize in the mainmenu, this will bring up a dialogbox where
it can be specified how many times the structure should be repeated in different directions and which program
to use for the visualization, choose RasMol and press OK.
In the window that now comes up you can rotate the structure by clicking on the structure and holding the
mouse-button down while moving the mouse around. When you have found a specially beautiful perspective
you can export the picture to an EPS-file by pressing Export Postscript in the VASE window. In the dialog
box write the file name you want to save the picture under. If you want to use the picture later in LATEX
give the file the extension .eps
In the visualization-program you can also play around with different ways of viewing the structure. If you
happen to press “export” in the menu and all menu items turn gray do not panic, it is simply because the
program now expects you to type a filename (but you cannot see what you type) and end it by pressing
enter.
When you have exported a picture of a structure to an EPS-file you can import it into your LATEX-report.
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If you want to print it, you can on a command-line type lp -dgps1-307 amazing-structure.eps (change
the printer- and filename according to reality).

10 Vary Structural Parameter

A useful feature where you can generate a series of structures, with some parameter being varied each time,
and calculating the potential energy of each one. It is good for finding the lowest energy version of a type of
structure (for example finding the equilibrium lattice constants of a crystal).

11 Units

In general in physics there are three base units, which are usually taken as those of mass, length and time.
In atomistic simulations it is more convenient to specify the unit of energy instead of time. Here the energy
units are electron-Volts (1 eV=1.6022×10−19J), the length units are Ångstrom (1 Å=10−10m=0.1 nm) and
the mass unit is the atomic mass unit (one twelfth of the mass of a carbon atom, 1 u=1.6605×10−27kg).
The unit of time is derived from these and is 10.18 fs or about 10−14s, but for convenience the interface has
been set-up for time to be entered in fs for things such as time steps in molecular dynamics.

12 Possible problems

I get an error when I try to run VASE Your path has not been set correctly. Did you follow the in-
structions under “Setting it up”?

The calculation is taking for ever You may have switched calculator to “dacapo” instead of asap. Press
Ctrl-C to end the program and start again. By default asap is used, otherwise push click on Switch calculator
to switch between the two. Alternatively, in a dynamical simulation, you may have asked for too many
time steps, or in any kind of simulation, too many atoms.

I can an error like “The height of the cell (...) must be larger than ...” EMT involves a range of
interaction which must always be less than half the size of the simulation box in directions where there
are periodic boundary conditions. If you get this error you must increase the size of the box.

My output file has not appeared Check first that the calculation has finished running (the Run button
should pop back up)
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Basic features of the xmgrace analysis program

Zoom

Autoscale

Figure 1: The xmgrace window as it looks before any data has been imported.

• In order to start xmgrace open a terminal and type xmgrace & (The & is not necessary; it just means
you can continue to use the same terminal window for other commands).

• If you’re plotting the data from the second column (’y’) in a datafile energyCurve.dat against the
data from the first (’x’) column just type xmgrace energyCurve.dat & at the commandline in a
terminal . If you need to plot columns other than the first two, see below.

• To see the coordinates of a particular point, look at the bar just under the menus which indicates
the coordinates of the cursor, while you move the cursor to the point of interest.

• To draw a box for zooming in on a part of a curve click first on the ’magnifying glass’ icon just below
the “Draw” button, then hold down the left button as you move the mouse from the top-left corner of
the box to the bottom right corner. The button to the right of the magnifying glass is the Autoscale
button (the button marked with “AS”) which will resize the plot so all curves are fully shown.

• To add symbols to a curve, choose Plot→Set appearance, and in the panel entitled “Symbol proper-
ties” you can choose the type, size and colour of symbols. If you want to remove the line joining the
symbols, or changes its appearance, use the panel entitled “Line properties”.
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• To remove current data from xmgrace

Data→Data set operations, left-click on the set you want to remove. To select multiple sets, hold down
shift while you click. Then right-click, choose “kill” or “kill data” (I’m still not sure what the difference
is myself) and OK.

• Importing new data into xmgrace (also for getting data from specific columns in the file)

Data→Import→Ascii. Choose the filename. Under “load as”, select “Block data”, then in the box
that appears, choose which column you want the y-values to come from. In Cbond, column 2 (counting
from 1 here) is usually total energy and column 3 is energy/atom. Press accept.

• Transforming data. For translating and rescaling the x and y coordinates of the data, go to Data→
Transformations →Geometric transformations. For more complicated transformations, such as dividing
each y-value by the square of the corresponding x-value, go to Data→Transformations→Evaluate
expression. In the “Formula” box you can type things such as y = S0.y/S0.x2, and select a “source
set” from the left-hand panel. A new set will be created. You may wish to remove the old set.

• Axis labelling

Plot→Axis properties ...

Select X or Y axis using the box at the top left of the dialog box, then write your description into the
“Axis label” box. Include the units! (write Angstrom for Å)

• Titles

It is wise to write your name and a brief description on the plot before printing, since many people
will be printing similar graphs!

Plot→Graph Appearance

Then write a description in the “title” field (for example “Dimer with 1 Hydrogen” ) and your name
and the date in the “subtitle” field, then press accept.

• To numerically differentiate your data, click on menus as follows:

Data→Transformations→Differences→Centered difference→Accept

The derivatives will appear as a second data set (you may need to click on Autoscale to see it)

• To fit the differentiated data to a straight line.

Data→Transformations→Regression→S1 + [Linear]

The square brackets indicate that this is the default value so you shouldn’t need to set it yourself. The
fit will be drawn over the data, and a box will appear telling you the formula of the line. You will only
need the slope (coefficient of X).

• To save an xmgrace session:

File→Save as, write the filename (recommended to end in .agr) under “Selection” at the bottom of the
box, then OK.

• To print or export a EPS-file for use in a LATEX document.from xmgrace:

Choose step 1a if you want to print onto paper, step 1b to print to a Postscript file for use with LATEX.

Step 1a: Choose File→Print setup, change the print command to “lpr -P gps1-307” (for the databar
in 307; otherwise replace with the name of whatever printer), and click “Accept”.

Step 1b: Choose File→Print setup, under “Device setup” change Postscript to EPS (Encapsulated
Postscript, which is the format LATEX uses for figures), and click the “Print to file” box under “Output”.
Change the filename if you want, then press Accept.

Step 2: File→Print to print the plot.

Step 1a only needs to be done once for a given session of xmgrace. Step 1b may have to be repeated
to allow you to change the filename for different plots.

2




